Back to overview
Degraded

API Overload Investigation

Oct 20 at 01:20pm CEST
Affected services
API
Content Cockpit

Resolved
Oct 20 at 01:41pm CEST

We are pleased to report that the situation has stabilized. Our investigation identified the cause as a substantial volume of improper requests from a customer's Point-of-Sale (POS) system, creating undue stress on our APIs and leading to service disruptions.

Immediate action has been taken to impose limitations on these requests, significantly reducing the overload and restoring system stability. We are currently in direct communication with the POS provider to address the source of these excessive requests and implement a long-term solution.

While the service is now stable, our team remains vigilant and continues monitoring the system's health closely to prevent any recurrence. We appreciate your understanding during this disruption and assure you of our commitment to maintaining the integrity and performance of our services.

Created
Oct 20 at 01:20pm CEST

We're aware of and actively investigating an issue causing overloading of our APIs, leading to service blackouts. Our technical team is working on identifying the root cause and implementing immediate solutions to stabilize performance. Users may experience intermittent disruptions during this time.

We apologize for any inconvenience and appreciate your patience as we work to resolve this critical issue swiftly. Further updates to follow.